NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

Arbitrary filepath traversal via URI injectionGHSA-cqh2-vc2f-q4fh

HIGHFix: cloudflare/cfrpki@a053a80

GHSA-cqh2-vc2f-q4fh is a high-severity (CVSS 7.4) Improper Input Validation vulnerability in github.com/cloudflare/cfrpki. A fix is available for github.com/cloudflare/cfrpki — see the affected versions and patch details below.

Also known asCVE-2021-3907GHSA-8459-6rc9-8vf8GO-2022-0248
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
1.20%2.43%3.66%4.89%1.9%4.2%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/cloudflare/cfrpki

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

OctoRPKI does not escape a URI with a filename containing "..", this allows a repository to create a file, (ex. rsync://example.org/repo/../../etc/cron.daily/evil.roa), which would then be written to disk outside the base cache folder. This could allow for remote code execution on the host machine OctoRPKI is running on.

Patches

For more information

If you have any questions or comments about this advisory email us at [email protected]

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/cloudflare/cfrpkiall versions1.4.4go get github.com/cloudflare/cfrpki@v1.4.4

Affected Products

2 products · 3 configurations
Application
octorpkicloudflare
< 1.3.0
range
OS
debian linuxdebian
2 versions
10.011.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/cloudflare/cfrpki, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/cloudflare/cfrpki to 1.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cqh2-vc2f-q4fh is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

OctoRPKI does not escape a URI with a filename containing "..", this allows a repository to create a file, (ex. `rsync://example.org/repo/../../etc/cron.daily/evil.roa`), which would then be written to disk outside the base cache folder. This could allow for remote code execution on the host machine OctoRPKI is running on. ## Patches ## For more information If you have any questions or comments about this advisory email us at [email protected]
O3 Security · Impact-Aware SCA

Is GHSA-cqh2-vc2f-q4fh in your dependencies?

Find it across Go, including transitive dependencies.

Arbitrary filepath traversal via URI injection (High 7.4)