NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2021-3908 — cfrpki

HIGH

CVE-2021-3908 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in github.com/cloudflare/cfrpki. A fix is available for github.com/cloudflare/cfrpki — see the affected versions and patch details below.

Infinite certificate chain depth results in OctoRPKI running forever

Also known asGHSA-g5gj-9ggf-9vmqGO-2022-0249
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.82%1.23%0.3%0.7%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/cloudflare/cfrpki

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

OctoRPKI (github.com/cloudflare/cfrpki/cmd/octorpki) does not limit the depth of a certificate chain, allowing for a CA to create children in an ad-hoc fashion, thereby making tree traversal never end.

For more information

If you have any questions or comments about this advisory email us at [email protected]

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/cloudflare/cfrpkiall versions1.4.0go get github.com/cloudflare/cfrpki@v1.4.0

Affected Products

2 products · 2 configurations
Application
octorpkicloudflare
< 1.3.0
range
OS
debian linuxdebian
1 version
11.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/cloudflare/cfrpki, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/cloudflare/cfrpki to 1.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3908 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

OctoRPKI (github.com/cloudflare/cfrpki/cmd/octorpki) does not limit the depth of a certificate chain, allowing for a CA to create children in an ad-hoc fashion, thereby making tree traversal never end. ### For more information If you have any questions or comments about this advisory email us at [email protected]
O3 Security · Impact-Aware SCA

Is CVE-2021-3908 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2021-3908: cfrpki — Fixed in 1.4.0