NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
CRITICAL severity

CVE-2021-3907 — cfrpki

CRITICALFix: cloudflare/cfrpki@a053a80

CVE-2021-3907 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in github.com/cloudflare/cfrpki. A fix is available for github.com/cloudflare/cfrpki — see the affected versions and patch details below.

Path traversal in github.com/cloudflare/cfrpki/cmd/octorpki

Also known asGHSA-8459-6rc9-8vf8GHSA-cqh2-vc2f-q4fhGO-2022-0248
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
1.20%2.43%3.66%4.89%1.9%4.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/cloudflare/cfrpki

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

OctoRPKI does not escape a URI with a filename containing "..", this allows a repository to create a file, (ex. rsync://example.org/repo/../../etc/cron.daily/evil.roa), which would then be written to disk outside the base cache folder. This could allow for remote code execution on the host machine OctoRPKI is running on.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/cloudflare/cfrpkiall versions1.4.3go get github.com/cloudflare/cfrpki@v1.4.3

Affected Products

2 products · 3 configurations
Application
octorpkicloudflare
< 1.3.0
range
OS
debian linuxdebian
2 versions
10.011.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/cloudflare/cfrpki, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/cloudflare/cfrpki to 1.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3907 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

### Impact In the case that a malicious TAL file is parsed pointing to a repository that provides a malicious ROA file which octorpki downloads, it is possible to bypass the current directory traversal mitigation to allow writing outside of the current directory. ### Patches No patch release has been made
O3 Security · Impact-Aware SCA

Is CVE-2021-3907 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2021-3907: cfrpki Path Traversal — Fixed in 1.4.3