Http4s Ember HTTP/2: unbounded continuation frame accumulationGHSA-cp4q-fqw9-4hf6
HIGHFix: http4s/http4s@6e8eccdGHSA-cp4q-fqw9-4hf6 is a high-severity (CVSS 7.5) CWE-770 vulnerability in org.http4s:http4s-ember-core_2.12. A fix is available for org.http4s:http4s-ember-core_2.12 — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-cp4q-fqw9-4hf6.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
GHSA-cp4q-fqw9-4hf6 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.
Where this sits among everything scored
Of 397,508 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
org.http4s:http4s-ember-core_2.12☕org.http4s:http4s-ember-core_2.13☕org.http4s:http4s-ember-core_3☕org.http4s:http4s-ember-core_2.13☕org.http4s:http4s-ember-core_3Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
When Ember receives an HTTP/2 HEADERS or PUSH_PROMISE frame without the END_HEADERS flag, it buffers the header block fragment and waits for subsequent CONTINUATION frames. These accumulate unbounded until the connection closes.
Impact
A remote, unauthenticated peer can exhaust the heap on any Ember endpoint that has HTTP/2 enabled:
- ember-server with
.withHttp2: any HTTP/2 client can trigger this against any reachable path (including paths that return 404). No authentication is required because the attack completes before the request is decoded. - ember-client with
.withHttp2: a malicious or compromised origin server can trigger this via the response header block. A single in-flight request is sufficient.
Memory consumption is bounded only by the attacker's upload bandwidth and the connection lifetime.
Prerequisites
EmberServerBuilderconfigured with.withHttp2.- For the server: the attacker can establish an HTTP/2 connection
- For the client: the application makes a request to an attacker-controlled origin. HTTP/2 incoming headers exceeding the configured size limit are buffer in order to generate an informative HTTP 413 response. If a client does not stop sending headers, this leads to memory exhaustion.
Patches
The fix bounds the accumulated header-block size at SETTINGS_MAX_HEADER_LIST_SIZE (derived from EmberServerBuilder.maxHeaderSize / EmberClientBuilder.maxResponseHeaderSize). When a CONTINUATION frame would push the accumulated block over that limit, the connection is terminated with GOAWAY. The receiveHeadersTimeout additionally bounds how long an incomplete header block may remain open.
Workarounds
- Disable HTTP/2 (
.withHttp2) until upgraded (default). It is off by default. - If HTTP/2 must remain enabled, place ember behind a reverse proxy that terminates HTTP/2 and speaks HTTP/1.1 to ember.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.http4s:http4s-ember-core_2.12 | all versions | 0.23.35org.http4s:http4s-ember-core_2.12:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-core_2.13 | all versions | 0.23.35org.http4s:http4s-ember-core_2.13:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-core_3 | all versions | 0.23.35org.http4s:http4s-ember-core_3:0.23.35 |
| ☕Maven | org.http4s:http4s-ember-core_2.13 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-ember-core_2.13:1.0.0-M47 |
| ☕Maven | org.http4s:http4s-ember-core_3 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-ember-core_3:1.0.0-M47 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.http4s:http4s-ember-core_2.12, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.http4s:http4s-ember-core_2.12 to 0.23.35 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cp4q-fqw9-4hf6 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-cp4q-fqw9-4hf6 in your dependencies?
Find it across Maven, including transitive dependencies.