NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Ghost: Database Backup Path TraversalGHSA-cj62-hvv2-2q5h

MEDIUMFix: TryGhost/Ghost@f466c30

GHSA-cj62-hvv2-2q5h is a medium-severity (CVSS 5.5) Path Traversal vulnerability in ghost. A fix is available for ghost — see the affected versions and patch details below.

Also known asBIT-ghost-2026-70592CVE-2026-70592
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-cj62-hvv2-2q5h.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs38th percentile — riskier than 38% of all scored CVEsHighest risk
0.00%0.31%0.62%0.94%0.3%0.4%0.4%0.4%Sep 26Nov 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

8other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ghostnpm
31Kdownloads / week

Description

Impact

An Administrator-level user could remotely overwrite certain files on the filesystem leading to integrity and availability issues.

Vulnerable versions

This vulnerability is present in Ghost from 1.20.1 up to v6.54.0.

Patches

v6.54.1 contains a fix for this issue.

How to update

For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here.

If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here.

Workarounds

If upgrading immediately is not possible, set disableJSBackups to "true" by running:

$ ghost config set disableJSBackups true
$ ghost restart

References

Ghost thanks Jorian Woltjer of Aikido Security, Mitchell Benjamin of Revamp Studio, and meifukun for disclosing this vulnerability responsibly.

For more information

If you have any questions or comments about this advisory, email Ghost at [email protected].

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmghost≥ 1.20.1&&< 6.54.16.54.1npm install ghost@6.54.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ghost, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ghost to 6.54.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cj62-hvv2-2q5h is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

### Impact An Administrator-level user could remotely overwrite certain files on the filesystem leading to integrity and availability issues. ### Vulnerable versions This vulnerability is present in Ghost from 1.20.1 up to v6.54.0. ### Patches v6.54.1 contains a fix for this issue. ### How to update For self-hosters using Docker, find [Docker's official Ghost image here](https://hub.docker.com/_/ghost). Updating a Docker-based Ghost instance [is documented here](https://docs.ghost.org/install/docker#updating-ghost). If your Ghost is a Ghost-CLI install see our documentation on [updati
O3 Security · Impact-Aware SCA

Is GHSA-cj62-hvv2-2q5h in your dependencies?

Find it across npm, including transitive dependencies.

Ghost: Database Backup Path Traversal (Medium 5.5)