Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-103288 — ghost

Fix: TryGhost/Ghost#28297

CVE-2026-103288 is a CWE-639 vulnerability in ghost. A fix is available for ghost — see the affected versions and patch details below.

Ghost 5.9.0 before 6.44.1 Authorization Bypass via Comment Like

Also known asBIT-ghost-2026-103288GHSA-qrh6-cwg3-343x
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-103288.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs10th percentile — riskier than 10% of all scored CVEsHighest risk

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
📦ghost

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects npm packages — download data is not available via public APIs for these ecosystems.

Description

Impact

An input validation issue allowed members to delete comment likes / dislikes that they were not authorized to delete.

Vulnerable versions

This vulnerability is present in Ghost from v5.9.0 up to v6.44.1.

Patches

v6.44.1 contains a fix for this issue.

How to update

For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here.

If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here.

References

Ghost thanks Adel Assakaf and Arthur Gurunlian as well as Geoffrey Diederichs of Escape for disclosing this vulnerability responsibly.

For more information

If you have any questions or comments about this advisory, email us at [email protected].

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmghost≥ 5.9.0&&< 6.44.16.44.1npm install ghost@6.44.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ghost, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ghost to 6.44.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-103288 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact An input validation issue allowed members to delete comment likes / dislikes that they were not authorized to delete. ### Vulnerable versions This vulnerability is present in Ghost from v5.9.0 up to v6.44.1. ### Patches v6.44.1 contains a fix for this issue. ### How to update For self-hosters using Docker, find [Docker's official Ghost image here](https://hub.docker.com/_/ghost). Updating a Docker-based Ghost instance [is documented here](https://docs.ghost.org/install/docker#updating-ghost). If your Ghost is a Ghost-CLI install see our documentation on [updating it to the l
O3 Security · Impact-Aware SCA

Is CVE-2026-103288 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-103288: ghost — Fixed in 6.44.1