CVE-2026-70592 is a medium-severity (CVSS 5.5) Path Traversal vulnerability in ghost. A fix is available for ghost — see the affected versions and patch details below.
Ghost: Database Backup Path Traversal
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-70592.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
ghostnpmDescription
Impact
An Administrator-level user could remotely overwrite certain files on the filesystem leading to integrity and availability issues.
Vulnerable versions
This vulnerability is present in Ghost from 1.20.1 up to v6.54.0.
Patches
v6.54.1 contains a fix for this issue.
How to update
For self-hosters using Docker, find Docker's official Ghost image here. Updating a Docker-based Ghost instance is documented here.
If your Ghost is a Ghost-CLI install see our documentation on updating it to the latest version here.
Workarounds
If upgrading immediately is not possible, set disableJSBackups to "true" by running:
$ ghost config set disableJSBackups true
$ ghost restart
References
Ghost thanks Jorian Woltjer of Aikido Security, Mitchell Benjamin of Revamp Studio, and meifukun for disclosing this vulnerability responsibly.
For more information
If you have any questions or comments about this advisory, email Ghost at [email protected].
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | ghost | ≥ 1.20.1&&< 6.54.1 | 6.54.1npm install ghost@6.54.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ghost, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ghost to 6.54.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-70592 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2026-70592 in your dependencies?
Find it across npm, including transitive dependencies.