NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

Laravel Risk of mass-assignment vulnerabilitiesGHSA-cc2w-ghc5-m5qr

GHSA-cc2w-ghc5-m5qr is a security vulnerability in illuminate/database. A fix is available for illuminate/database — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 29, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🐘illuminate/database

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Laravel 4.1.29 improves the column quoting for all database drivers. This protects your application from some mass assignment vulnerabilities when not using the fillable property on models. If you are using the fillable property on your models to protect against mass assignment, your application is not vulnerable. However, if you are using guarded and are passing a user controlled array into an "update" or "save" type function, you should upgrade to 4.1.29 immediately as your application may be at risk of mass assignment.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistilluminate/database≥ 4.0.0&&< 4.1.294.1.29composer require illuminate/database:^4.1.29

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for illuminate/database, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update illuminate/database to 4.1.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-cc2w-ghc5-m5qr is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Laravel 4.1.29 improves the column quoting for all database drivers. This protects your application from some mass assignment vulnerabilities when not using the fillable property on models. If you are using the fillable property on your models to protect against mass assignment, your application is not vulnerable. However, if you are using guarded and are passing a user controlled array into an "update" or "save" type function, you should upgrade to 4.1.29 immediately as your application may be at risk of mass assignment.
O3 Security · Impact-Aware SCA

Is GHSA-cc2w-ghc5-m5qr in your dependencies?

Find it across Packagist, including transitive dependencies.

Laravel Risk of mass-assignment vulnerabilities