NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

SQL Server LIMIT / OFFSET SQL Injection in laravel/framework and illuminate/databaseGHSA-4mg9-vhxq-vm7j

GHSA-4mg9-vhxq-vm7j is a security vulnerability in laravel/framework. A fix is available for laravel/framework — see the affected versions and patch details below.

Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Dec 2, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

4 pkgs affected
🐘laravel/framework🐘laravel/framework🐘illuminate/database🐘illuminate/database

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Those using SQL Server with Laravel and allowing user input to be passed directly to the limit and offset functions are vulnerable to SQL injection. Other database drivers such as MySQL and Postgres are not affected by this vulnerability.

Patches

This problem has been patched on Laravel versions 6.20.26, 7.30.5, and 8.40.0.

Workarounds

You may workaround this vulnerability by ensuring that only integers are passed to the limit and offset functions, as well as the skip and take functions.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistlaravel/framework≥ 8.0.0&&< 8.40.08.40.0composer require laravel/framework:^8.40.0
🐘Packagistlaravel/frameworkall versions6.20.26composer require laravel/framework:^6.20.26
🐘Packagistilluminate/database≥ 8.0.0&&< 8.40.08.40.0composer require illuminate/database:^8.40.0
🐘Packagistilluminate/databaseall versions6.20.26composer require illuminate/database:^6.20.26

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for laravel/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update laravel/framework to 8.40.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4mg9-vhxq-vm7j is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

### Impact Those using SQL Server with Laravel and allowing user input to be passed directly to the `limit` and `offset` functions are vulnerable to SQL injection. Other database drivers such as MySQL and Postgres are not affected by this vulnerability. ### Patches This problem has been patched on Laravel versions 6.20.26, 7.30.5, and 8.40.0. ### Workarounds You may workaround this vulnerability by ensuring that only integers are passed to the `limit` and `offset` functions, as well as the `skip` and `take` functions.
O3 Security · Impact-Aware SCA

Is GHSA-4mg9-vhxq-vm7j in your dependencies?

Find it across Packagist, including transitive dependencies.

SQL Server LIMIT / OFFSET SQL Injection in…