NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
MEDIUM severity

Publify has Improper Access ControlsGHSA-c273-c6vg-4pv5

MEDIUMFix: publify/publify@c0aba87

GHSA-c273-c6vg-4pv5 is a medium-severity (CVSS 4.3) CWE-639 vulnerability in publify_core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for publify_core — see the affected versions and patch details below.

Also known asBIT-publify-2022-1810CVE-2022-1810
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.89%1.34%0.1%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎publify_core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

A low-privileged user can modify and delete admin articles by changing the value of the article[id] parameter prior to 9.2.9.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemspublify_coreall versions9.2.9bundle update publify_core --conservative

Affected Products

1 product · 1 configurations
Application
publifypublify_project
< 9.2.9
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for publify_core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update publify_core to 9.2.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-c273-c6vg-4pv5 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A low-privileged user can modify and delete admin articles by changing the value of the `article[id]` parameter prior to 9.2.9.
O3 Security · Impact-Aware SCA

Is GHSA-c273-c6vg-4pv5 in your dependencies?

Find it across RubyGems, including transitive dependencies.

Publify has Improper Access Controls (Medium 4.3)