path-to-regexp outputs backtracking regular expressionsGHSA-9wv6-86v2-598j
HIGHFix: pillarjs/path-to-regexp@29b96b4GHSA-9wv6-86v2-598j is a high-severity (CVSS 7.5) CWE-1333 vulnerability in path-to-regexp. A fix is available for path-to-regexp — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-9wv6-86v2-598j.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
path-to-regexpnpmDescription
Impact
A bad regular expression is generated any time you have two parameters within a single segment, separated by something that is not a period (.). For example, /:a-:b.
Patches
For users of 0.1, upgrade to 0.1.10. All other users should upgrade to 8.0.0.
These versions add backtrack protection when a custom regex pattern is not provided:
They do not protect against vulnerable user supplied capture groups. Protecting against explicit user patterns is out of scope for old versions and not considered a vulnerability.
Version 7.1.0 can enable strict: true and get an error when the regular expression might be bad.
Version 8.0.0 removes the features that can cause a ReDoS.
Workarounds
All versions can be patched by providing a custom regular expression for parameters after the first in a single segment. As long as the custom regular expression does not match the text before the parameter, you will be safe. For example, change /:a-:b to /:a-:b([^-/]+).
If paths cannot be rewritten and versions cannot be upgraded, another alternative is to limit the URL length. For example, halving the attack string improves performance by 4x faster.
Details
Using /:a-:b will produce the regular expression /^\/([^\/]+?)-([^\/]+?)\/?$/. This can be exploited by a path such as /a${'-a'.repeat(8_000)}/a. OWASP has a good example of why this occurs, but the TL;DR is the /a at the end ensures this route would never match but due to naive backtracking it will still attempt every combination of the :a-:b on the repeated 8,000 -a.
Because JavaScript is single threaded and regex matching runs on the main thread, poor performance will block the event loop and can lead to a DoS. In local benchmarks, exploiting the unsafe regex will result in performance that is over 1000x worse than the safe regex. In a more realistic environment using Express v4 and 10 concurrent connections, this translated to average latency of ~600ms vs 1ms.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | path-to-regexp | ≥ 0.2.0&&< 1.9.0 | 1.9.0npm install path-to-regexp@1.9.0 |
| 📦npm | path-to-regexp | all versions | 0.1.10npm install path-to-regexp@0.1.10 |
| 📦npm | path-to-regexp | ≥ 7.0.0&&< 8.0.0 | 8.0.0npm install path-to-regexp@8.0.0 |
| 📦npm | path-to-regexp | ≥ 2.0.0&&< 3.3.0 | 3.3.0npm install path-to-regexp@3.3.0 |
| 📦npm | path-to-regexp | ≥ 4.0.0&&< 6.3.0 | 6.3.0npm install path-to-regexp@6.3.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for path-to-regexp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update path-to-regexp to 1.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-9wv6-86v2-598j is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for GHSA-9wv6-86v2-598j (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Discovery 1 for RHEL 9 | discovery/discovery-server-rhel9:1.12.0-1 | RHSA-2025:1249 |
| HawtIO 4.0.0 for Red Hat build of Apache Camel 4 | path-to-regexp | RHSA-2024:11023 |
| multicluster engine for Kubernetes 2.6 for RHEL 8 | multicluster-engine/assisted-image-service-rhel8:v2.6.4-4 | RHSA-2024:11293 |
| multicluster engine for Kubernetes 2.7 for RHEL 8 | multicluster-engine/assisted-service-8-rhel8:v2.7.2-1 | RHSA-2024:10857 |
| NETWORK-OBSERVABILITY-1.7.0-RHEL-9 | network-observability/network-observability-cli-rhel9:v1.7.0-67 | RHSA-2024:8014 |
| Red Hat Advanced Cluster Management for Kubernetes 2.11 for RHEL 9 | rhacm2/acm-cluster-permission-rhel9:v2.11.4-4 | RHSA-2024:11381 |
| Red Hat Advanced Cluster Management for Kubernetes 2.12 for RHEL 9 | rhacm2/acm-cli-rhel9:v2.12.1-4 | RHSA-2024:10865 |
| Red Hat Ansible Automation Platform 2.4 for RHEL 8 | automation-controller-0:4.5.13-1.el8ap | RHSA-2024:10762 |
Frequently Asked Questions
Is GHSA-9wv6-86v2-598j in your dependencies?
Find it across npm, including transitive dependencies.