CVE-2024-52798 — path-to-regexp
Fix: pillarjs/path-to-regexp@f01c26aCVE-2024-52798 is a CWE-1333 vulnerability in path-to-regexp. A fix is available for path-to-regexp — see the affected versions and patch details below.
path-to-regexp Unpatched `path-to-regexp` ReDoS in 0.1.x
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-52798.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
path-to-regexpnpmDescription
Impact
The regular expression that is vulnerable to backtracking can be generated in versions before 0.1.12 of path-to-regexp, originally reported in CVE-2024-45296
Patches
Upgrade to 0.1.12.
Workarounds
Avoid using two parameters within a single path segment, when the separator is not . (e.g. no /:a-:b). Alternatively, you can define the regex used for both parameters and ensure they do not overlap to allow backtracking.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | path-to-regexp | all versions | 0.1.12npm install path-to-regexp@0.1.12 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for path-to-regexp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update path-to-regexp to 0.1.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-52798 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability exists because of an incomplete fix for CVE-2024-45296.
Avoid using two parameters within a single path segment when the separator is not, for example, /:a-:b. Alternatively, you can define the regex used for both parameters and ensure they do not overlap to allow backtracking.Source: Red Hat security advisory for CVE-2024-52798 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Discovery 1 for RHEL 9 | discovery/discovery-server-rhel9:1.12.0-1 | RHSA-2025:1249 |
| HawtIO HawtIO 4.2.0 | io.hawt-project | RHSA-2025:8761 |
| Red Hat Developer Hub 1.3 on RHEL 9 | rhdh-hub-container-1.3-138 | RHBA-2025:0610 |
| Red Hat OpenShift Container Platform 4.17 | openshift4/nmstate-console-plugin-rhel9:v4.17.0-202501301204.p0.gcffdc60.assembly.stream.el9 | RHSA-2025:0875 |
| Red Hat OpenShift Container Platform 4.17 | openshift4/ose-networking-console-plugin-rhel9:v4.17.0-202501241234.p0.g2c4e34f.assembly.stream.el9 | RHSA-2025:0876 |
| Red Hat OpenShift Container Platform 4.18 | openshift4/ingress-node-firewall-rhel9:v4.18.0-202501230001.p0.g1e43b4c.assembly.stream.el9 | RHSA-2024:6121 |
| Red Hat OpenShift Container Platform 4.18 | openshift4/aws-kms-encryption-provider-rhel9:v4.18.0-202501230001.p0.g088dcaf.assembly.stream.el9 | RHSA-2024:6122 |
| Red Hat OpenShift Service Mesh 2.5 for RHEL 8 | openshift-service-mesh/kiali-ossmc-rhel8:1.73.17-2 | RHSA-2025:1051 |
Frequently Asked Questions
Is CVE-2024-52798 in your dependencies?
Find it across npm, including transitive dependencies.