CVE-2026-4926 — path-to-regexp
HIGHCVE-2026-4926 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in path-to-regexp. A fix is available for path-to-regexp — see the affected versions and patch details below.
path-to-regexp vulnerable to Denial of Service via sequential optional groups
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-4926.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
path-to-regexpnpmDescription
Impact
A bad regular expression is generated any time you have multiple sequential optional groups (curly brace syntax), such as {a}{b}{c}:z. The generated regex grows exponentially with the number of groups, causing denial of service.
Patches
Fixed in version 8.4.0.
Workarounds
Limit the number of sequential optional groups in route patterns. Avoid passing user-controlled input as route patterns.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | path-to-regexp | ≥ 8.0.0&&< 8.4.0 | 8.4.0npm install path-to-regexp@8.4.0 |
Affected Products
path-to-regexppillarjsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for path-to-regexp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update path-to-regexp to 8.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-4926 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This is an Important flaw in `path-to-regexp` that can lead to a Denial of Service. The vulnerability occurs when specially crafted input containing multiple sequential optional groups is used to generate regular expressions, causing exponential resource consumption. The Red Hat Advanced Cluster Security is not…
To mitigate this vulnerability, limit the use of multiple sequential optional groups in route patterns within applications that use `path-to-regexp`. Additionally, avoid directly passing user-controlled input as route patterns to prevent the generation of maliciously crafted regular expressions.Source: Red Hat security advisory for CVE-2026-4926 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Cryostat 4 on RHEL 9 | cryostat/cryostat-openshift-console-plugin-rhel9:4.2.0-9 | RHSA-2026:17789 |
| Red Hat Ansible Automation Platform 2.5 for RHEL 8 | automation-gateway-0:2.5.20260422-3.el8ap | RHSA-2026:24761 |
| Red Hat Ansible Automation Platform 2.6 for RHEL 9 | automation-platform-ui-0:2.6.9-1.el9ap | RHSA-2026:24762 |
| Migration Toolkit for Virtualization 2.10 | migration-toolkit-virtualization/mtv-console-plugin-rhel9:1779139872 | RHSA-2026:19409 |
| Migration Toolkit for Virtualization 2.9 | migration-toolkit-virtualization/mtv-console-plugin-rhel9:1778927462 | RHSA-2026:19410 |
| Red Hat Ansible Automation Platform 2.6 | ansible-automation-platform-tech-preview/mcp-server-rhel9:1777386606 | RHSA-2026:13545 |
| Red Hat Ansible Automation Platform 2.6 | ansible-automation-platform-26/gateway-rhel9:1779773804 | RHSA-2026:24866 |
| Red Hat Developer Hub 1.8 | rhdh/rhdh-hub-rhel9:1776784286 | RHSA-2026:9742 |
Frequently Asked Questions
Is CVE-2026-4926 in your dependencies?
Find it across npm, including transitive dependencies.