OpenStack Object Storage (Swift) allows remote attackers to cause a denial of serviceGHSA-972c-cfv8-2hq8
HIGHGHSA-972c-cfv8-2hq8 is a high-severity (CVSS 7.5) CWE-399 vulnerability in swift. A fix is available for swift — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
swiftReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
OpenStack Object Storage (Swift) before 2.4.0 does not properly close client connections, which allows remote attackers to cause a denial of service (proxy-server resource consumption) via a series of interrupted requests to a Large Object URL.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | swift | all versions | 2.4.0pip install --upgrade 'swift==2.4.0' |
Affected Products
swiftopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for swift, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update swift to 2.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-972c-cfv8-2hq8 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 | openstack-swift-0:1.13.1-8.el6ost | RHSA-2016:0126 |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 | openstack-swift-0:1.13.1-8.el7ost | RHSA-2016:0127 |
| Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7 | openstack-swift-0:2.2.0-6.el7ost | RHSA-2016:0128 |
| Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7 | openstack-swift-0:2.3.0-3.el7ost | RHSA-2016:0155 |
| Red Hat Gluster Storage 3.1 for RHEL 6 | openstack-swift-0:1.13.1-8.el6ost | RHSA-2016:0329 |
| Red Hat Gluster Storage 3.1 for RHEL 7 | openstack-swift-0:1.13.1-8.el7ost | RHSA-2016:0328 |
Frequently Asked Questions
Is GHSA-972c-cfv8-2hq8 in your dependencies?
Find it across PyPI, including transitive dependencies.