Apache Tomcat: CLIENT_CERT authentication does not fail as expectedGHSA-95jq-rwvf-vjx4
CRITICALFix: apache/tomcat@721591fGHSA-95jq-rwvf-vjx4 is a critical-severity (CVSS 9.1) Improper Authentication vulnerability in org.apache.tomcat:tomcat-coyote-ffm. A fix is available for org.apache.tomcat:tomcat-coyote-ffm — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-95jq-rwvf-vjx4.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat-coyote-ffm☕org.apache.tomcat:tomcat-coyote-ffm☕org.apache.tomcat:tomcat-coyote-ffm☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat, Apache Tomcat Native.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M7 through 10.1.52, from 9.0.83 through 9.0.115; Apache Tomcat Native: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39, from 1.3.0 through 1.3.6, from 2.0.0 through 2.0.13.
Users are recommended to upgrade to version Tomcat Native 1.3.7 or 2.0.14 and Tomcat 11.0.20, 10.1.53 and 9.0.116, which fix the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat-coyote-ffm | ≥ 9.0.83&&< 9.0.116 | 9.0.116org.apache.tomcat:tomcat-coyote-ffm:9.0.116 |
| ☕Maven | org.apache.tomcat:tomcat-coyote-ffm | ≥ 10.1.0-M7&&< 10.1.53 | 10.1.53org.apache.tomcat:tomcat-coyote-ffm:10.1.53 |
| ☕Maven | org.apache.tomcat:tomcat-coyote-ffm | ≥ 11.0.0-M1&&< 11.0.20 | 11.0.20org.apache.tomcat:tomcat-coyote-ffm:11.0.20 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 9.0.83&&< 9.0.116 | 9.0.116org.apache.tomcat:tomcat:9.0.116 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 10.1.0-M7&&< 10.1.53 | 10.1.53org.apache.tomcat:tomcat:10.1.53 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 11.0.0-M1&&< 11.0.20 | 11.0.20org.apache.tomcat:tomcat:11.0.20 |
Affected Products
tomcatapachetomcat nativeapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-coyote-ffm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat-coyote-ffm to 9.0.116 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-95jq-rwvf-vjx4 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This Moderate vulnerability in Apache Tomcat and Apache Tomcat Native arises when CLIENT_CERT authentication is configured with "soft fail" disabled. This misconfiguration can lead to an authentication bypass, potentially allowing unauthorized access to protected resources. Red Hat Enterprise Linux versions 6, 7, 8,…
To mitigate this issue, ensure that CLIENT_CERT authentication is configured to strictly enforce client certificate validation. Review the Apache Tomcat conf/server.xml configuration. For SSLHostConfig or Connector elements, set the clientAuth attribute to required or ensure softFail is enabled if optional client certificate authentication is desired. A restart of the Apache Tomcat service is necessary for these configuration changes to apply.Source: Red Hat security advisory for GHSA-95jq-rwvf-vjx4 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 10 | tomcat9-1:9.0.117-1.el10_2 | RHSA-2026:25341 |
| Red Hat Enterprise Linux 10.0 Extended Update Support | tomcat9-1:9.0.120-1.el10_0 | RHSA-2026:67163 |
| Red Hat Enterprise Linux 8 | tomcat-1:9.0.120-1.el8_10 | RHSA-2026:68677 |
| Red Hat Enterprise Linux 8.8 Telecommunications Update Service | tomcat-1:9.0.120-1.el8_8 | RHSA-2026:68680 |
| Red Hat Enterprise Linux 9 | tomcat-1:9.0.117-1.el9_8 | RHSA-2026:26323 |
| Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions | tomcat-1:9.0.120-1.el9_2 | RHSA-2026:68678 |
| Red Hat Enterprise Linux 9.4 Update Services for SAP Solutions | tomcat-1:9.0.120-1.el9_4 | RHSA-2026:68679 |
| Red Hat Enterprise Linux 9.6 Extended Update Support | tomcat-1:9.0.120-1.el9_6 | RHSA-2026:68659 |
Frequently Asked Questions
Is GHSA-95jq-rwvf-vjx4 in your dependencies?
Find it across Maven, including transitive dependencies.