NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2026-34500 — tomcat-coyote-ffm

MEDIUMFix: apache/tomcat@29b56a5

CVE-2026-34500 is a medium-severity (CVSS 6.5) Improper Authentication vulnerability in org.apache.tomcat:tomcat-coyote-ffm. A fix is available for org.apache.tomcat:tomcat-coyote-ffm — see the affected versions and patch details below.

Apache Tomcat: OCSP checks sometimes soft-fail with FFM even when soft-fail is disabled

Also known asBIT-tomcat-2026-34500GHSA-24j9-x2wg-9qv6
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-34500.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs40th percentile — riskier than 40% of all scored CVEsHighest risk
0.00%0.32%0.65%0.97%0.2%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
☕org.apache.tomcat:tomcat-coyote-ffm☕org.apache.tomcat:tomcat-coyote-ffm☕org.apache.tomcat:tomcat-coyote-ffm

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled and FFM is used in Apache Tomcat.

This issue affects Apache Tomcat: from 11.0.0-M14 through 11.0.20, from 10.1.22 through 10.1.53, from 9.0.92 through 9.0.116.

Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fixes the issue.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.tomcat:tomcat-coyote-ffm≥ 9.0.92&&< 9.0.1179.0.117org.apache.tomcat:tomcat-coyote-ffm:9.0.117
☕Mavenorg.apache.tomcat:tomcat-coyote-ffm≥ 10.1.22&&< 10.1.5410.1.54org.apache.tomcat:tomcat-coyote-ffm:10.1.54
☕Mavenorg.apache.tomcat:tomcat-coyote-ffm≥ 11.0.0-M14&&< 11.0.2111.0.21org.apache.tomcat:tomcat-coyote-ffm:11.0.21

Affected Products

1 product · 16 configurations
Application
tomcatapache
≥ 11.0.1 && < 11.0.21
1 version
11.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-coyote-ffm, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.tomcat:tomcat-coyote-ffm to 9.0.117 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-34500 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This issue only affects Tomcat builds with FFM support enabled. In Red Hat Enterprise Linux, this support is only available in Tomcat package in Red Hat Enterprise Linux versions 9.8 and later, and 10.2 and later, as the feature requires Java 22 or later.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2026-34500 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 10tomcat9-1:9.0.117-1.el10_2RHSA-2026:25341
Red Hat Enterprise Linux 9tomcat-1:9.0.117-1.el9_8RHSA-2026:26323
Red Hat JBoss Web Server 6.2.3tomcatRHSA-2026:20406
Red Hat JBoss Web Server 6.2 on RHEL 10jws6-tomcat-0:10.1.49-13.redhat_00011.1.el10jwsRHSA-2026:20405

Frequently Asked Questions

CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled and FFM is used in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M14 through 11.0.20, from 10.1.22 through 10.1.53, from 9.0.92 through 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fixes the issue.
O3 Security · Impact-Aware SCA

Is CVE-2026-34500 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-34500: tomcat-coyote-ffm — Fixed in 9.0.117