NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
LOW severity

python-keystoneclient unsecure user password updateGHSA-8q2m-pwxf-jc7g

LOWFix: openstack/python-keystoneclient@f2e0818

GHSA-8q2m-pwxf-jc7g is a low-severity (CVSS 2.9) Information Exposure vulnerability in python-keystoneclient. A fix is available for python-keystoneclient — see the affected versions and patch details below.

Also known asCVE-2013-2013PYSEC-2013-24
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs31th percentile — riskier than 31% of all scored CVEsHighest risk
0.00%0.29%0.58%0.87%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍python-keystoneclient

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The user-password-update command in python-keystoneclient before 0.2.4 accepts the new password in the --password argument, which allows local users to obtain sensitive information by listing the process.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpython-keystoneclientall versions0.2.4pip install --upgrade 'python-keystoneclient==0.2.4'

Affected Products

1 product · 2 configurations
Application
python-keystoneclientopenstack
≤ 0.2.3
1 version
0.2.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for python-keystoneclient, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update python-keystoneclient to 0.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8q2m-pwxf-jc7g is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

The user-password-update command in python-keystoneclient before 0.2.4 accepts the new password in the --password argument, which allows local users to obtain sensitive information by listing the process.
O3 Security · Impact-Aware SCA

Is GHSA-8q2m-pwxf-jc7g in your dependencies?

Find it across PyPI, including transitive dependencies.

GHSA-8q2m-pwxf-jc7g: python — Fixed in 0.2.4