NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Apache Syncope Improper Input Validation vulnerabilityGHSA-8pxv-x6jq-5vw9

MEDIUMFix: apache/syncope@12e65f5

GHSA-8pxv-x6jq-5vw9 is a medium-severity (CVSS 6.5) Cross-site Scripting (XSS) vulnerability in org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui. A fix is available for org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui — see the affected versions and patch details below.

Also known asCVE-2024-38503
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-8pxv-x6jq-5vw9.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%2.51%5.03%7.54%4.5%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui☕org.apache.syncope.client.idrepo:syncope-client-idrepo-console

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

When editing a user, group or any object in the Syncope Console, HTML tags could be added to any text field and could lead to potential exploits. The same vulnerability was found in the Syncope Enduser, when editing "Personal Information" or "User Requests".

Users are recommended to upgrade to version 3.0.8, which fixes this issue.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui≥ 2.1.0&&< 3.0.83.0.8org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui:3.0.8
☕Mavenorg.apache.syncope.client.idrepo:syncope-client-idrepo-console≥ 2.1.0&&< 3.0.83.0.8org.apache.syncope.client.idrepo:syncope-client-idrepo-console:3.0.8

Affected Products

1 product · 2 configurations
Application
syncopeapache
≥ 3.0.0 && ≤ 2.1.14
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui to 3.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8pxv-x6jq-5vw9 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

When editing a user, group or any object in the Syncope Console, HTML tags could be added to any text field and could lead to potential exploits. The same vulnerability was found in the Syncope Enduser, when editing "Personal Information" or "User Requests". Users are recommended to upgrade to version 3.0.8, which fixes this issue.
O3 Security · Impact-Aware SCA

Is GHSA-8pxv-x6jq-5vw9 in your dependencies?

Find it across Maven, including transitive dependencies.

Apache Syncope Improper Input Validation vulnerability