NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2026-23795 — syncope-client-idrepo-con…

MEDIUM

CVE-2026-23795 is a medium-severity (CVSS 4.9) XML External Entity (XXE) vulnerability in org.apache.syncope.client.idrepo:syncope-client-idrepo-console. A fix is available for org.apache.syncope.client.idrepo:syncope-client-idrepo-console — see the affected versions and patch details below.

Apache Syncope: Console XXE on Keymaster parameters

Also known asGHSA-73f3-rqqf-2j54
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.85%1.70%2.55%0.1%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.syncope.client.idrepo:syncope-client-idrepo-console☕org.apache.syncope.client.idrepo:syncope-client-idrepo-console

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Improper Restriction of XML External Entity Reference vulnerability in Apache Syncope Console. An administrator with adequate entitlements to create or edit Keymaster parameters via Console can construct malicious XML text to launch an XXE attack, thereby causing sensitive data leakage occurs.

This issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3.

Users are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.syncope.client.idrepo:syncope-client-idrepo-console≥ 3.0.0&&< 3.0.163.0.16org.apache.syncope.client.idrepo:syncope-client-idrepo-console:3.0.16
☕Mavenorg.apache.syncope.client.idrepo:syncope-client-idrepo-console≥ 4.0.0&&< 4.0.44.0.4org.apache.syncope.client.idrepo:syncope-client-idrepo-console:4.0.4

Affected Products

1 product · 2 configurations
Application
syncopeapache
≥ 4.0.0 && < 4.0.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.syncope.client.idrepo:syncope-client-idrepo-console, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.syncope.client.idrepo:syncope-client-idrepo-console to 3.0.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-23795 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Improper Restriction of XML External Entity Reference vulnerability in Apache Syncope Console. An administrator with adequate entitlements to create or edit Keymaster parameters via Console can construct malicious XML text to launch an XXE attack, thereby causing sensitive data leakage occurs. This issue affects Apache Syncope: from 3.0 through 3.0.15, from 4.0 through 4.0.3. Users are recommended to upgrade to version 3.0.16 / 4.0.4, which fix this issue.
O3 Security · Impact-Aware SCA

Is CVE-2026-23795 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-23795: syncope-client-idrepo — Fixed in 3.0.16