CVE-2024-38503 is a low-severity (CVSS 3.9) Cross-site Scripting (XSS) vulnerability in org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui. A fix is available for org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui — see the affected versions and patch details below.
Apache Syncope: HTML tags can be injected into Console or Enduser text fields
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-38503.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui☕org.apache.syncope.client.idrepo:syncope-client-idrepo-consoleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
When editing a user, group or any object in the Syncope Console, HTML tags could be added to any text field and could lead to potential exploits. The same vulnerability was found in the Syncope Enduser, when editing “Personal Information” or “User Requests”.
Users are recommended to upgrade to version 3.0.8, which fixes this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui | ≥ 2.1.0&&< 3.0.8 | 3.0.8org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui:3.0.8 |
| ☕Maven | org.apache.syncope.client.idrepo:syncope-client-idrepo-console | ≥ 2.1.0&&< 3.0.8 | 3.0.8org.apache.syncope.client.idrepo:syncope-client-idrepo-console:3.0.8 |
Affected Products
syncopeapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.syncope.client.idrepo:syncope-client-idrepo-common-ui to 3.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-38503 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-38503 in your dependencies?
Find it across Maven, including transitive dependencies.