Drupal Core Cross-site scripting vulnerabilityGHSA-8jj2-x2gc-ggm7
MEDIUMGHSA-8jj2-x2gc-ggm7 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/core🐘drupal/core🐘drupal/core🐘drupal/drupal🐘drupal/drupal🐘drupal/drupal🐘drupal/drupalReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting vulnerability in Drupal Core. Drupal AJAX API does not disable JSONP by default, allowing for an XSS attack. This issue affects: Drupal Drupal Core 7.x versions prior to 7.73; 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 8.8.0&&< 8.8.10 | 8.8.10composer require drupal/core:^8.8.10 |
| 🐘Packagist | drupal/core | ≥ 8.9.0&&< 8.9.6 | 8.9.6composer require drupal/core:^8.9.6 |
| 🐘Packagist | drupal/core | ≥ 9.0.0&&< 9.0.6 | 9.0.6composer require drupal/core:^9.0.6 |
| 🐘Packagist | drupal/core | ≥ 7.0.0&&< 7.73 | 7.73composer require drupal/core:^7.73 |
| 🐘Packagist | drupal/drupal | ≥ 7.0.0&&< 7.73 | 7.73composer require drupal/drupal:^7.73 |
| 🐘Packagist | drupal/drupal | ≥ 8.8.0&&< 8.8.10 | 8.8.10composer require drupal/drupal:^8.8.10 |
Affected Products
drupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 8.8.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8jj2-x2gc-ggm7 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-8jj2-x2gc-ggm7 in your dependencies?
Find it across Packagist, including transitive dependencies.