NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2020-13666 — core

MEDIUM

CVE-2020-13666 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.

Drupal Core Cross-site scripting vulnerability

Also known asBIT-drupal-2020-13666DRUPAL-CORE-2020-007GHSA-8jj2-x2gc-ggm7
Published
Updated
Affected
8 pkgs
Patched
8 / 8
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
0.00%1.22%2.43%3.65%0.5%2.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

8 pkgs affected
🐘drupal/core🐘drupal/core🐘drupal/core🐘drupal/core🐘drupal/drupal🐘drupal/drupal🐘drupal/drupal🐘drupal/drupal

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting vulnerability in Drupal Core. Drupal AJAX API does not disable JSONP by default, allowing for an XSS attack. This issue affects: Drupal Drupal Core 7.x versions prior to 7.73; 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.

Affected Packages

8 total 8 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/core≥ 8.8.0&&< 8.8.108.8.10composer require drupal/core:^8.8.10
🐘Packagistdrupal/core≥ 8.9.0&&< 8.9.68.9.6composer require drupal/core:^8.9.6
🐘Packagistdrupal/core≥ 9.0.0&&< 9.0.69.0.6composer require drupal/core:^9.0.6
🐘Packagistdrupal/core≥ 7.0.0&&< 7.737.73composer require drupal/core:^7.73
🐘Packagistdrupal/drupal≥ 7.0.0&&< 7.737.73composer require drupal/drupal:^7.73
🐘Packagistdrupal/drupal≥ 8.8.0&&< 8.8.108.8.10composer require drupal/drupal:^8.8.10

Affected Products

1 product · 4 configurations
Application
drupaldrupal
≥ 9.0.0 && < 9.0.6
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/core to 8.8.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-13666 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting vulnerability in Drupal Core. Drupal AJAX API does not disable JSONP by default, allowing for an XSS attack. This issue affects: Drupal Drupal Core 7.x versions prior to 7.73; 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.
O3 Security · Impact-Aware SCA

Is CVE-2020-13666 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-13666: core XSS — Fixed in 8.8.10