NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

OpenStack Dashboard (Horizon) Cross-site scripting (XSS) vulnerability in the Host Aggregates interfaceGHSA-8g68-2hcj-h8vg

Fix: openstack/horizon@ba2c98a

GHSA-8g68-2hcj-h8vg is a Cross-site Scripting (XSS) vulnerability in horizon. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for horizon — see the affected versions and patch details below.

Also known asCVE-2014-3594PYSEC-2026-641
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.10%0.93%1.75%2.57%0.6%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍horizon

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the Host Aggregates interface in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2, and Juno before Juno-3 allows remote administrators to inject arbitrary web script or HTML via a new host aggregate name.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIhorizonall versions8.0.0a0pip install --upgrade 'horizon==8.0.0a0'

Affected Products

2 products · 5 configurations
Application
horizonopenstack
≥ 2014.1 && < 2014.1.2
2 versions
juno-1juno-2
OS
opensuseopensuse
1 version
13.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for horizon, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update horizon to 8.0.0a0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8g68-2hcj-h8vg is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
OpenStack 4 for RHEL 6python-django-horizon-0:2013.2.3-3.el6ostRHSA-2014:1188
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6python-django-horizon-0:2014.1.2-2.el6ostRHSA-2014:1336
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7python-django-horizon-0:2014.1.2-2.el7ostRHSA-2014:1335

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the Host Aggregates interface in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2, and Juno before Juno-3 allows remote administrators to inject arbitrary web script or HTML via a new host aggregate name.
O3 Security · Impact-Aware SCA

Is GHSA-8g68-2hcj-h8vg in your dependencies?

Find it across PyPI, including transitive dependencies.

OpenStack Dashboard (Horizon) Cross-site scripting…