NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

Access bypass in Drupal coreGHSA-8849-cv9f-vccm

GHSA-8849-cv9f-vccm is a CWE-863 vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.

Also known asBIT-drupal-2023-31250CVE-2023-31250DRUPAL-CORE-2023-005
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-8849-cv9f-vccm.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs46th percentile — riskier than 46% of all scored CVEsHighest risk
0.00%0.35%0.69%1.04%0.4%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

4 pkgs affected
🐘drupal/core🐘drupal/core🐘drupal/core🐘drupal/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The file download facility doesn't sufficiently sanitize file paths in certain situations. This may result in users gaining access to private files that they should not have access to. Some sites may require configuration changes following this security release. Review the release notes for your Drupal version if you have issues accessing private files after updating.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/core≥ 10.0.0&&< 10.0.810.0.8composer require drupal/core:^10.0.8
🐘Packagistdrupal/core≥ 9.5.0&&< 9.5.89.5.8composer require drupal/core:^9.5.8
🐘Packagistdrupal/core≥ 9.0.0&&< 9.4.149.4.14composer require drupal/core:^9.4.14
🐘Packagistdrupal/core≥ 7.0.0&&< 7.967.96composer require drupal/core:^7.96

Affected Products

1 product · 4 configurations
Application
drupaldrupal
≥ 10.0 && < 10.0.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/core to 10.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8849-cv9f-vccm is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

The file download facility doesn't sufficiently sanitize file paths in certain situations. This may result in users gaining access to private files that they should not have access to. Some sites may require configuration changes following this security release. Review the release notes for your Drupal version if you have issues accessing private files after updating.
O3 Security · Impact-Aware SCA

Is GHSA-8849-cv9f-vccm in your dependencies?

Find it across Packagist, including transitive dependencies.

Access bypass in Drupal core