CVE-2023-31250 — core
MEDIUMCVE-2023-31250 is a medium-severity (CVSS 6.5) CWE-863 vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
Drupal core - Moderately critical - Access bypass - SA-CORE-2023-005
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-31250.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/core🐘drupal/core🐘drupal/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The file download facility doesn't sufficiently sanitize file paths in certain situations. This may result in users gaining access to private files that they should not have access to. Some sites may require configuration changes following this security release. Review the release notes for your Drupal version if you have issues accessing private files after updating.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 10.0.0&&< 10.0.8 | 10.0.8composer require drupal/core:^10.0.8 |
| 🐘Packagist | drupal/core | ≥ 9.5.0&&< 9.5.8 | 9.5.8composer require drupal/core:^9.5.8 |
| 🐘Packagist | drupal/core | ≥ 9.0.0&&< 9.4.14 | 9.4.14composer require drupal/core:^9.4.14 |
| 🐘Packagist | drupal/core | ≥ 7.0.0&&< 7.96 | 7.96composer require drupal/core:^7.96 |
Affected Products
drupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 10.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-31250 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2023-31250 in your dependencies?
Find it across Packagist, including transitive dependencies.