NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

OpenStack Keystone allows context-dependent attackers to bypass access restrictionsGHSA-8833-qrvm-wc3h

Fix: openstack/keystone@7402f5e

GHSA-8833-qrvm-wc3h is a Improper Authentication vulnerability in keystone. A fix is available for keystone — see the affected versions and patch details below.

Also known asCVE-2013-0282PYSEC-2026-652
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.00%0.75%1.51%2.26%0.5%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍keystone

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

OpenStack Keystone Grizzly before 2013.1, Folsom 2012.1.3 and earlier, and Essex does not properly check if the (1) user, (2) tenant, or (3) domain is enabled when using EC2-style authentication, which allows context-dependent attackers to bypass access restrictions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIkeystoneall versions8.0.0a0pip install --upgrade 'keystone==8.0.0a0'

Affected Products

1 product · 5 configurations
Application
keystoneopenstack
≥ 2012.2 && ≤ 2012.2.4
1 version
2013.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for keystone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update keystone to 8.0.0a0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-8833-qrvm-wc3h is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
OpenStack Folsom for RHEL 6openstack-keystone-0:2012.2.3-3.el6ostRHSA-2013:0596

Frequently Asked Questions

OpenStack Keystone Grizzly before 2013.1, Folsom 2012.1.3 and earlier, and Essex does not properly check if the (1) user, (2) tenant, or (3) domain is enabled when using EC2-style authentication, which allows context-dependent attackers to bypass access restrictions.
O3 Security · Impact-Aware SCA

Is GHSA-8833-qrvm-wc3h in your dependencies?

Find it across PyPI, including transitive dependencies.

OpenStack Keystone allows context-dependent attackers…