NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

ThinkCMF Cross Site Request Forgerly (CSRF) vulnerabilityGHSA-842m-vp3r-qwwr

MEDIUMFix: thinkcmf/thinkcmf@321faa2

GHSA-842m-vp3r-qwwr is a medium-severity (CVSS 6.5) Cross-Site Request Forgery (CSRF) vulnerability in thinkcmf/thinkcmf. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for thinkcmf/thinkcmf — see the affected versions and patch details below.

Also known asCVE-2020-18151
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs41th percentile — riskier than 41% of all scored CVEsHighest risk
0.00%0.32%0.65%0.97%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘thinkcmf/thinkcmf

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross Site Request Forgery (CSRF) vulnerability in ThinkCMF v5.1.0, which can add an admin account.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistthinkcmf/thinkcmfall versions6.0.8composer require thinkcmf/thinkcmf:^6.0.8

Affected Products

1 product · 1 configurations
Application
thinkcmfthinkcmf
1 version
5.1.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for thinkcmf/thinkcmf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update thinkcmf/thinkcmf to 6.0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-842m-vp3r-qwwr is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Cross Site Request Forgery (CSRF) vulnerability in ThinkCMF, which can add an admin account.
O3 Security · Impact-Aware SCA

Is GHSA-842m-vp3r-qwwr in your dependencies?

Find it across Packagist, including transitive dependencies.

ThinkCMF Cross Site Request Forgerly (CSRF) vulnerability