CVE-2021-40616 — thinkcmf
MEDIUMCVE-2021-40616 is a medium-severity (CVSS 6.5) CWE-425 vulnerability in thinkcmf/thinkcmf. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for thinkcmf/thinkcmf — see the affected versions and patch details below.
Incorrect Authorization in thinkcmf
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
thinkcmf/thinkcmfReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
thinkcmf v5.1.7 has an unauthorized vulnerability. The attacker can modify the password of the administrator account with id 1 through the background user management group permissions. The use condition is that the background user management group authority is required.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | thinkcmf/thinkcmf | all versions | 6.0.0composer require thinkcmf/thinkcmf:^6.0.0 |
Affected Products
thinkcmfthinkcmfResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for thinkcmf/thinkcmf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update thinkcmf/thinkcmf to 6.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-40616 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2021-40616 in your dependencies?
Find it across Packagist, including transitive dependencies.