NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2020-25915 — thinkcmf

MEDIUMFix: thinkcmf/thinkcmf@27e1fbe

CVE-2020-25915 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in thinkcmf/thinkcmf. A fix is available for thinkcmf/thinkcmf — see the affected versions and patch details below.

ThinkCMF Cross-site Scripting Vulnerability

Also known asGHSA-4847-gqxx-v9xp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2020-25915.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs39th percentile — riskier than 39% of all scored CVEsHighest risk
0.00%0.36%0.71%1.07%0.4%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘thinkcmf/thinkcmf

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross Site Scripting (XSS) vulnerability in UserController.php in ThinkCMF version 5.1.5, allows attackers to execute arbitrary code via crafted user_login.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistthinkcmf/thinkcmfall versions5.1.7composer require thinkcmf/thinkcmf:^5.1.7

Affected Products

1 product · 1 configurations
Application
thinkcmfthinkcmf
1 version
5.1.5

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for thinkcmf/thinkcmf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update thinkcmf/thinkcmf to 5.1.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-25915 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross Site Scripting (XSS) vulnerability in UserController.php in ThinkCMF version 5.1.5, allows attackers to execute arbitrary code via crafted user_login.
O3 Security · Impact-Aware SCA

Is CVE-2020-25915 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-25915: thinkcmf RCE — Fixed in 5.1.7