GeoServer's MapML HTML Page vulnerable to Stored Cross-Site Scripting (XSS)GHSA-7x76-57fr-m5r5
MEDIUMFix: geoserver/geoserver#7175GHSA-7x76-57fr-m5r5 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in org.geoserver.extension:gs-mapml. A fix is available for org.geoserver.extension:gs-mapml — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-7x76-57fr-m5r5.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.geoserver.extension:gs-mapml☕org.geoserver.extension:gs-mapmlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A stored cross-site scripting (XSS) vulnerability exists that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the MapML HTML Page. The MapML extension must be installed and access to the MapML HTML Page is available to all users although data security may limit users' ability to trigger the XSS.
Impact
If an attacker can control a script that is executed in the victim's browser, then they can typically fully compromise that user. Amongst other things, the attacker can:
1 .Perform any action within the application that the user can perform. 2. View any information that the user is able to view. 3. Modify any information that the user is able to modify. 4. Initiate interactions with other application users, including malicious attacks, that will appear to originate from the initial victim user.
References
https://osgeo-org.atlassian.net/browse/GEOS-11154 https://github.com/geoserver/geoserver/pull/7175
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.geoserver.extension:gs-mapml | all versions | 2.23.4org.geoserver.extension:gs-mapml:2.23.4 |
| ☕Maven | org.geoserver.extension:gs-mapml | ≥ 2.24.0&&< 2.24.1 | 2.24.1org.geoserver.extension:gs-mapml:2.24.1 |
Affected Products
geoservergeoserverDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.geoserver.extension:gs-mapml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.geoserver.extension:gs-mapml to 2.23.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7x76-57fr-m5r5 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-7x76-57fr-m5r5 in your dependencies?
Find it across Maven, including transitive dependencies.