NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2024-23819 — gs-mapml

MEDIUMFix: geoserver/geoserver@6f04adb

CVE-2024-23819 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in org.geoserver.extension:gs-mapml. A fix is available for org.geoserver.extension:gs-mapml — see the affected versions and patch details below.

GeoServer Stored Cross-Site Scripting (XSS) vulnerability in MapML HTML Page

Also known asGHSA-7x76-57fr-m5r5
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-23819.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs37th percentile — riskier than 37% of all scored CVEsHighest risk
0.00%0.31%0.62%0.93%0.4%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.geoserver.extension:gs-mapml☕org.geoserver.extension:gs-mapml

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Summary

A stored cross-site scripting (XSS) vulnerability exists that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the MapML HTML Page. The MapML extension must be installed and access to the MapML HTML Page is available to all users although data security may limit users' ability to trigger the XSS.

Impact

If an attacker can control a script that is executed in the victim's browser, then they can typically fully compromise that user. Amongst other things, the attacker can:

1 .Perform any action within the application that the user can perform. 2. View any information that the user is able to view. 3. Modify any information that the user is able to modify. 4. Initiate interactions with other application users, including malicious attacks, that will appear to originate from the initial victim user.

References

https://osgeo-org.atlassian.net/browse/GEOS-11154 https://github.com/geoserver/geoserver/pull/7175

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.geoserver.extension:gs-mapmlall versions2.23.4org.geoserver.extension:gs-mapml:2.23.4
☕Mavenorg.geoserver.extension:gs-mapml≥ 2.24.0&&< 2.24.12.24.1org.geoserver.extension:gs-mapml:2.24.1

Affected Products

1 product · 2 configurations
Application
geoservergeoserver
< 2.23.4
1 version
2.24.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.geoserver.extension:gs-mapml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.geoserver.extension:gs-mapml to 2.23.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-23819 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Summary A stored cross-site scripting (XSS) vulnerability exists that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the MapML HTML Page. The MapML extension must be installed and access to the MapML HTML Page is available to all users although data security may limit users' ability to trigger the XSS. ### Impact If an attacker can control a script that is executed in the victim's browser, then they can typically fully compromise that us
O3 Security · Impact-Aware SCA

Is CVE-2024-23819 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2024-23819: gs-mapml XSS — Fixed in 2.23.4