Spring Security OAuth vulnerable to remote code execution (RCE) via specially crafted request using whitelabel viewsGHSA-7q9c-h23x-65fq
HIGHGHSA-7q9c-h23x-65fq is a high-severity (CVSS 8.8) CWE-19 vulnerability in org.springframework.security.oauth:spring-security-oauth2. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.springframework.security.oauth:spring-security-oauth2 — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.springframework.security.oauth:spring-security-oauth2☕org.springframework.security.oauth:spring-security-oauth2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
When processing authorization requests using the whitelabel views in Spring Security OAuth 2.0.0 to 2.0.9 and 1.0.0 to 1.0.5, the response_type parameter value was executed as Spring SpEL which enabled a malicious user to trigger remote code execution via the crafting of the value for response_type.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.springframework.security.oauth:spring-security-oauth2 | ≥ 2.0.0&&< 2.0.10 | 2.0.10org.springframework.security.oauth:spring-security-oauth2:2.0.10 |
| ☕Maven | org.springframework.security.oauth:spring-security-oauth2 | ≥ 1.0.0&&< 1.0.5 | 1.0.5org.springframework.security.oauth:spring-security-oauth2:1.0.5 |
Affected Products
spring security oauthpivotalResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.security.oauth:spring-security-oauth2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.springframework.security.oauth:spring-security-oauth2 to 2.0.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7q9c-h23x-65fq is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
How to detect GHSA-7q9c-h23x-65fq
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id ghsa-7q9c-h23x-65fq -u https://target- Template
- Spring Security OAuth2 Remote Command Execution
- Severity
- high
- Impact
- Successful exploitation of this vulnerability can lead to remote code execution, compromising the affected system.
- Remediation
- Users of 1.0.x should not use whitelabel views for approval and error pages. Users of 2.0.x should either not use whitelabel views for approval and error pages or upgrade to 2.0.10 or later.
Template by ProjectDiscovery nuclei-templates (princechaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is GHSA-7q9c-h23x-65fq in your dependencies?
Find it across Maven, including transitive dependencies.