NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2018-15758 — spring-security-oauth2

HIGHFix: spring-attic/spring-security-oauth@4082ec7

CVE-2018-15758 is a high-severity (CVSS 8.1) vulnerability in org.springframework.security.oauth:spring-security-oauth2. A fix is available for org.springframework.security.oauth:spring-security-oauth2 — see the affected versions and patch details below.

Authorization bypass in org.springframework.security.oauth:spring-security-oauth2

Also known asGHSA-h8w4-qv99-f7vj
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.00%0.90%1.80%2.70%0.3%2.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.springframework.security.oauth:spring-security-oauth2☕org.springframework.security.oauth:spring-security-oauth2☕org.springframework.security.oauth:spring-security-oauth2☕org.springframework.security.oauth:spring-security-oauth2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Spring Security OAuth, versions 2.3 prior to 2.3.4, and 2.2 prior to 2.2.3, and 2.1 prior to 2.1.3, and 2.0 prior to 2.0.16, and older unsupported versions could be susceptible to a privilege escalation under certain conditions. A malicious user or attacker can craft a request to the approval endpoint that can modify the previously saved authorization request and lead to a privilege escalation on the subsequent approval. This scenario can happen if the application is configured to use a custom approval endpoint that declares AuthorizationRequest as a controller method argument. This vulnerability exposes applications that meet all of the following requirements: Act in the role of an Authorization Server (e.g. @EnableAuthorizationServer) and use a custom Approval Endpoint that declares AuthorizationRequest as a controller method argument. This vulnerability does not expose applications that: Act in the role of an Authorization Server and use the default Approval Endpoint, act in the role of a Resource Server only (e.g. @EnableResourceServer), act in the role of a Client only (e.g. @EnableOAuthClient).

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.security.oauth:spring-security-oauth2≥ 2.0.0&&< 2.0.162.0.16org.springframework.security.oauth:spring-security-oauth2:2.0.16
☕Mavenorg.springframework.security.oauth:spring-security-oauth2≥ 2.1.0&&< 2.1.32.1.3org.springframework.security.oauth:spring-security-oauth2:2.1.3
☕Mavenorg.springframework.security.oauth:spring-security-oauth2≥ 2.2.0&&< 2.2.3.RELEASE2.2.3.RELEASEorg.springframework.security.oauth:spring-security-oauth2:2.2.3.RELEASE
☕Mavenorg.springframework.security.oauth:spring-security-oauth2≥ 2.3.0&&< 2.3.4.RELEASE2.3.4.RELEASEorg.springframework.security.oauth:spring-security-oauth2:2.3.4.RELEASE

Affected Products

1 product · 5 configurations
Application
spring security oauthpivotal_software
≥ 2.3.0 && ≤ 1.0.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.security.oauth:spring-security-oauth2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.security.oauth:spring-security-oauth2 to 2.0.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-15758 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Fuse 7.4.0spring-security-oauthRHSA-2019:2413

Frequently Asked Questions

Spring Security OAuth, versions 2.3 prior to 2.3.4, and 2.2 prior to 2.2.3, and 2.1 prior to 2.1.3, and 2.0 prior to 2.0.16, and older unsupported versions could be susceptible to a privilege escalation under certain conditions. A malicious user or attacker can craft a request to the approval endpoint that can modify the previously saved authorization request and lead to a privilege escalation on the subsequent approval. This scenario can happen if the application is configured to use a custom approval endpoint that declares AuthorizationRequest as a controller method argument. This vulnerabil
O3 Security · Impact-Aware SCA

Is CVE-2018-15758 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-15758: spring-security PrivEsc — Fixed in 2.0.16