NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2018-1260 — spring-security-oauth2

CRITICAL

CVE-2018-1260 is a critical-severity (CVSS 9.8) Code Injection vulnerability in org.springframework.security.oauth:spring-security-oauth2. EPSS puts its 30-day exploitation probability at 10.6% (96th percentile). A fix is available for org.springframework.security.oauth:spring-security-oauth2 — see the affected versions and patch details below.

Spring Security OAuth vulnerable to remote code execution (RCE)

Also known asGHSA-rrpm-pj7p-7j9q
Published
Updated
Affected
5 pkgs
Patched
4 / 5
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
10.6%probability of exploitation in next 30 days
Moderate Risk-0.20%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
0.00%21.8%43.7%65.5%52.3%10.6%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
☕org.springframework.security.oauth:spring-security-oauth2☕org.springframework.security.oauth:spring-security-oauth2☕org.springframework.security.oauth:spring-security-oauth2☕org.springframework.security.oauth:spring-security-oauth2☕org.springframework.security.oauth:spring-security-oauth2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Spring Security OAuth, versions 2.3 prior to 2.3.3, 2.2 prior to 2.2.2, 2.1 prior to 2.1.2, 2.0 prior to 2.0.15 and older unsupported versions contains a remote code execution vulnerability. A malicious user or attacker can craft an authorization request to the authorization endpoint that can lead to remote code execution when the resource owner is forwarded to the approval endpoint.

Affected Packages

5 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.security.oauth:spring-security-oauth2≥ 2.3.0&&< 2.3.32.3.3org.springframework.security.oauth:spring-security-oauth2:2.3.3
☕Mavenorg.springframework.security.oauth:spring-security-oauth2≥ 2.2.0&&< 2.2.22.2.2org.springframework.security.oauth:spring-security-oauth2:2.2.2
☕Mavenorg.springframework.security.oauth:spring-security-oauth2≥ 2.1.0&&< 2.1.22.1.2org.springframework.security.oauth:spring-security-oauth2:2.1.2
☕Mavenorg.springframework.security.oauth:spring-security-oauth2≥ 2.0.0&&< 2.0.152.0.15org.springframework.security.oauth:spring-security-oauth2:2.0.15
☕Mavenorg.springframework.security.oauth:spring-security-oauth2≥ 1.0.0No fix

Affected Products

1 product · 4 configurations
Application
spring security oauthpivotal_software
≥ 2.3 && ≤ 2.3.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.security.oauth:spring-security-oauth2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.security.oauth:spring-security-oauth2 to 2.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1260 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Frequently Asked Questions

Spring Security OAuth, versions 2.3 prior to 2.3.3, 2.2 prior to 2.2.2, 2.1 prior to 2.1.2, 2.0 prior to 2.0.15 and older unsupported versions contains a remote code execution vulnerability. A malicious user or attacker can craft an authorization request to the authorization endpoint that can lead to remote code execution when the resource owner is forwarded to the approval endpoint.
O3 Security · Impact-Aware SCA

Is CVE-2018-1260 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2018-1260: spring-security RCE — Fixed in 2.3.3