Apache Zeppelin exposes server resources to unauthenticated attackersGHSA-7pgf-ppxw-8624
HIGHFix: apache/zeppelin#4841GHSA-7pgf-ppxw-8624 is a high-severity (CVSS 7.5) CWE-664 vulnerability in org.apache.zeppelin:zeppelin-interpreter. A fix is available for org.apache.zeppelin:zeppelin-interpreter — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-7pgf-ppxw-8624.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.zeppelin:zeppelin-interpreter☕org.apache.zeppelin:zeppelin-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The attacker can use the raft server protocol in an unauthenticated way. The attacker can see the server's resources, including directories and files.
This issue affects Apache Zeppelin: from 0.10.1 up to 0.12.0.
Users are recommended to upgrade to version 0.12.0, which fixes the issue by removing the Cluster Interpreter.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.zeppelin:zeppelin-interpreter | ≥ 0.10.1&&< 0.12.0 | 0.12.0org.apache.zeppelin:zeppelin-interpreter:0.12.0 |
| ☕Maven | org.apache.zeppelin:zeppelin-server | ≥ 0.10.1&&< 0.12.0 | 0.12.0org.apache.zeppelin:zeppelin-server:0.12.0 |
Affected Products
zeppelinapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.zeppelin:zeppelin-interpreter, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.zeppelin:zeppelin-interpreter to 0.12.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7pgf-ppxw-8624 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-7pgf-ppxw-8624 in your dependencies?
Find it across Maven, including transitive dependencies.