CVE-2024-31868 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.zeppelin:zeppelin-interpreter. A fix is available for org.apache.zeppelin:zeppelin-interpreter — see the affected versions and patch details below.
Apache Zeppelin: XSS vulnerability in the helium module
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-31868.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.zeppelin:zeppelin-interpreterReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin.
The attackers can modify helium.json and exposure XSS attacks to normal users. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1.
Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.zeppelin:zeppelin-interpreter | ≥ 0.8.2&&< 0.11.1 | 0.11.1org.apache.zeppelin:zeppelin-interpreter:0.11.1 |
Affected Products
zeppelinapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.zeppelin:zeppelin-interpreter, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.zeppelin:zeppelin-interpreter to 0.11.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-31868 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-31868 in your dependencies?
Find it across Maven, including transitive dependencies.