CVE-2024-31862 is a medium-severity (CVSS 5.3) Improper Input Validation vulnerability in org.apache.zeppelin:zeppelin-server. A fix is available for org.apache.zeppelin:zeppelin-server — see the affected versions and patch details below.
Apache Zeppelin: Denial of service with invalid notebook name
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-31862.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.zeppelin:zeppelin-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Improper Input Validation vulnerability in Apache Zeppelin when creating a new note from Zeppelin's UI. This issue affects Apache Zeppelin from 0.10.1 before 0.11.0.
Users are recommended to upgrade to version 0.11.0, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.zeppelin:zeppelin-server | ≥ 0.10.1&&< 0.11.0 | 0.11.0org.apache.zeppelin:zeppelin-server:0.11.0 |
Affected Products
zeppelinapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.zeppelin:zeppelin-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.zeppelin:zeppelin-server to 0.11.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-31862 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-31862 in your dependencies?
Find it across Maven, including transitive dependencies.