NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven📦 npm.NET NuGet🐘 Packagist💎 RubyGems
Not in CISA KEV
MEDIUM severity

Bootstrap Cross-site Scripting vulnerabilityGHSA-7mvr-5x2g-wfc8

MEDIUMFix: twbs/bootstrap#26630

GHSA-7mvr-5x2g-wfc8 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.webjars:bootstrap. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.webjars:bootstrap — see the affected versions and patch details below.

Also known asCVE-2018-14042
Published
Updated
Affected
13 pkgs
Patched
13 / 13
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
1.76%2.68%3.61%4.53%2.3%4.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

13 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

15Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
bootstrapnpm
8.1Mdownloads / week

Description

In Bootstrap starting in version 2.3.0 and prior to versions 3.4.0 and 4.1.2, XSS is possible in the data-container property of tooltip. This is similar to CVE-2018-14041.

Affected Packages

13 total 13 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.webjars:bootstrap≥ 4.0.0&&< 4.1.24.1.2org.webjars:bootstrap:4.1.2
☕Mavenorg.webjars:bootstrap≥ 2.3.0&&< 3.4.03.4.0org.webjars:bootstrap:3.4.0
📦npmbootstrap≥ 4.0.0&&< 4.1.24.1.2npm install bootstrap@4.1.2
📦npmbootstrap≥ 2.3.0&&< 3.4.03.4.0npm install bootstrap@3.4.0
📦npmbootstrap-sass≥ 2.0.4&&< 3.4.03.4.0npm install bootstrap-sass@3.4.0
.NETNuGetbootstrap≥ 4.0.0&&< 4.1.24.1.2dotnet add package bootstrap --version 4.1.2

Affected Products

1 product · 11 configurations
Application
bootstrapgetbootstrap
≥ 4.0.0 && < 4.1.2
1 version
4.0.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars:bootstrap, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.webjars:bootstrap to 4.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7mvr-5x2g-wfc8 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat Satellite 6.2 and newer versions don't use the bootstrap library, hence are not affected by this flaw. Red Hat CloudForms 4.6 and newer versions include the vulnerable component, but there is no risk of exploitation, since there is no possible vector to access the vulnerability. Older Red Hat CloudForms…

ProductFixed inAdvisory
Red Hat Enterprise Linux 7ipa-0:4.6.8-5.el7RHSA-2020:3936
Red Hat Enterprise Linux 8idm:client-8030020200923172426.05ac3f11RHSA-2020:4670
Red Hat Enterprise Linux 8pki-core:10.6-8030020200911215836.5ff1562fRHSA-2020:4847
Red Hat JBoss Enterprise Application Platform 7.4.9org.jboss.hal/hal-console:3.3.16.Final-redhat-00001RHSA-2023:0556
Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8eap7-hal-console-0:3.3.16-1.Final_redhat_00001.1.el8eapRHSA-2023:0553
Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 9eap7-hal-console-0:3.3.16-1.Final_redhat_00001.1.el9eapRHSA-2023:0554
Red Hat JBoss Enterprise Application Platform 7.4 on RHEL 7eap7-hal-console-0:3.3.16-1.Final_redhat_00001.1.el7eapRHSA-2023:0552
Red Hat OpenStack Platform 13.0 (Queens)python-XStatic-Bootstrap-SCSS-0:3.4.1.0-1.el7ostRHSA-2020:5571

Frequently Asked Questions

In Bootstrap starting in version 2.3.0 and prior to versions 3.4.0 and 4.1.2, XSS is possible in the data-container property of tooltip. This is similar to CVE-2018-14041.
O3 Security · Impact-Aware SCA

Is GHSA-7mvr-5x2g-wfc8 in your dependencies?

Find it across Maven, npm, NuGet, including transitive dependencies.

Bootstrap Cross-site Scripting vulnerability (Medium 6.1)