NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

Malicious PDF can inject JavaScript into PDF ViewerGHSA-7jg2-jgv3-fmr4

HIGHFix: mozilla/pdf.js#9659

GHSA-7jg2-jgv3-fmr4 is a high-severity (CVSS 8.8) Code Injection vulnerability in pdfjs-dist. EPSS puts its 30-day exploitation probability at 10.2% (96th percentile). A fix is available for pdfjs-dist — see the affected versions and patch details below.

Also known asCVE-2018-5158
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
10.2%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
0.40%17.9%35.4%52.9%43.0%10.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

4Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
pdfjs-distnpm
51.9Mdownloads / week

Description

The PDF viewer does not sufficiently sanitize PostScript calculator functions, allowing malicious JavaScript to be injected through a crafted PDF file. This JavaScript can then be run with the permissions of the PDF viewer by its worker. This vulnerability affects Firefox ESR < 52.8, Firefox < 60 and PDF.js < 2.0.550.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmpdfjs-dist≥ 2.0.0&&< 2.0.5502.0.550npm install pdfjs-dist@2.0.550
📦npmpdfjs-distall versions1.10.100npm install pdfjs-dist@1.10.100

Affected Products

9 products · 19 configurations
OS
ubuntu linuxcanonical
4 versions
14.0416.0417.1018.04
OS
debian linuxdebian
3 versions
7.08.09.0
Application
firefoxmozilla
< 60.0
range
OS
enterprise linux desktopredhat
2 versions
6.07.0
OS
enterprise linux serverredhat
2 versions
6.07.0
OS
enterprise linux server ausredhat
1 version
7.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pdfjs-dist, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pdfjs-dist to 2.0.550 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7jg2-jgv3-fmr4 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Enterprise Linux 6firefox-0:52.8.0-1.el6_9RHSA-2018:1414
Red Hat Enterprise Linux 7firefox-0:52.8.0-1.el7_5RHSA-2018:1415

Frequently Asked Questions

The PDF viewer does not sufficiently sanitize PostScript calculator functions, allowing malicious JavaScript to be injected through a crafted PDF file. This JavaScript can then be run with the permissions of the PDF viewer by its worker. This vulnerability affects Firefox ESR < 52.8, Firefox < 60 and PDF.js < 2.0.550.
O3 Security · Impact-Aware SCA

Is GHSA-7jg2-jgv3-fmr4 in your dependencies?

Find it across npm, including transitive dependencies.

Malicious PDF can inject JavaScript into PDF Viewer