NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-16633 — pdfjs-dist

CVE-2026-16633 is a security vulnerability in pdfjs-dist. A fix is available for pdfjs-dist — see the affected versions and patch details below.

PDF.js: Arbitrary JavaScript execution upon opening a malicious PDF

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Sep 10, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

4Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
pdfjs-distnpm
53.9Mdownloads / week

Description

Impact

If PDF.js is used to load a malicious PDF, and PDF.js is configured with enableScripting set to true (which is the default value) and no CSP for disallowing script-src, unrestricted attacker-controlled JavaScript will be executed in the context of the hosting domain.

Patches

Workarounds

Set enableScripting to false or set a CSP.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmpdfjs-dist≥ 5.6.83&&< 6.2.1086.2.108npm install pdfjs-dist@6.2.108

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pdfjs-dist, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pdfjs-dist to 6.2.108 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-16633 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact If PDF.js is used to load a malicious PDF, and PDF.js is configured with `enableScripting` set to true (which is the default value) and no CSP for disallowing script-src, unrestricted attacker-controlled JavaScript will be executed in the context of the hosting domain. ### Patches ### Workarounds Set `enableScripting` to `false` or set a CSP.
O3 Security · Impact-Aware SCA

Is CVE-2026-16633 in your dependencies?

Find it across npm, including transitive dependencies.