CVE-2018-5158 is a high-severity (CVSS 8.8) Code Injection vulnerability in pdfjs-dist. EPSS puts its 30-day exploitation probability at 10.2% (96th percentile). A fix is available for pdfjs-dist — see the affected versions and patch details below.
Malicious PDF can inject JavaScript into PDF Viewer
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
pdfjs-distnpmDescription
The PDF viewer does not sufficiently sanitize PostScript calculator functions, allowing malicious JavaScript to be injected through a crafted PDF file. This JavaScript can then be run with the permissions of the PDF viewer by its worker. This vulnerability affects Firefox ESR < 52.8, Firefox < 60 and PDF.js < 2.0.550.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | pdfjs-dist | ≥ 2.0.0&&< 2.0.550 | 2.0.550npm install pdfjs-dist@2.0.550 |
| 📦npm | pdfjs-dist | all versions | 1.10.100npm install pdfjs-dist@1.10.100 |
Affected Products
ubuntu linuxcanonicaldebian linuxdebianfirefoxmozillaenterprise linux desktopredhatenterprise linux serverredhatenterprise linux server ausredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pdfjs-dist, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pdfjs-dist to 2.0.550 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-5158 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | firefox-0:52.8.0-1.el6_9 | RHSA-2018:1414 |
| Red Hat Enterprise Linux 7 | firefox-0:52.8.0-1.el7_5 | RHSA-2018:1415 |
Frequently Asked Questions
Is CVE-2018-5158 in your dependencies?
Find it across npm, including transitive dependencies.