NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Cross site scripting Vulnerability in backstage Software CatalogGHSA-7hv8-3fr9-j2hv

MEDIUMFix: backstage/backstage@3d13719

GHSA-7hv8-3fr9-j2hv is a medium-severity (CVSS 6.8) Cross-site Scripting (XSS) vulnerability in @backstage/core-components. A fix is available for @backstage/core-components — see the affected versions and patch details below.

Also known asCVE-2023-25571
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-7hv8-3fr9-j2hv.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs40th percentile — riskier than 40% of all scored CVEsHighest risk
0.00%0.40%0.81%1.21%0.7%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@backstage/core-componentsnpm
335Kdownloads / week
@backstage/catalog-modelnpm
970Kdownloads / week
@backstage/plugin-catalog-backendnpm
228Kdownloads / week

Description

Backstage is an open platform for building developer portals. @backstage/catalog-model prior to version 1.2.0, @backstage/core-components prior to 0.12.4, and @backstage/plugin-catalog-backend prior to 1.7.2 are affected by a cross-site scripting vulnerability. This vulnerability allows a malicious actor with access to add or modify content in an instance of the Backstage software catalog to inject script URLs in the entities stored in the catalog. If users of the catalog then click on said URLs, that can lead to an XSS attack.

This vulnerability has been patched in both the frontend and backend implementations. The default Link component from @backstage/core-components version 1.2.0 and greater will now reject javascript: URLs, and there is a global override of window.open to do the same. In addition, the catalog model v0.12.4 and greater as well as the catalog backend v1.7.2 and greater now has additional validation built in that prevents javascript: URLs in known annotations. As a workaround, the general practice of limiting access to modifying catalog content and requiring code reviews greatly help mitigate this vulnerability.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
📦npm@backstage/core-componentsall versions0.12.4npm install @backstage/core-components@0.12.4
📦npm@backstage/catalog-modelall versions1.2.0npm install @backstage/catalog-model@1.2.0
📦npm@backstage/plugin-catalog-backendall versions1.7.2npm install @backstage/plugin-catalog-backend@1.7.2

Affected Products

3 products · 3 configurations
Application
backstage catalog-modellinuxfoundation
< 1.2.0
range
Application
backstage core-componentslinuxfoundation
< 0.12.4
range
Application
backstage plugin-catalog-backendlinuxfoundation
< 1.7.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @backstage/core-components, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @backstage/core-components to 0.12.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7hv8-3fr9-j2hv is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact This vulnerability allows a malicious actor with access to add or modify content in an instance of the Backstage software catalog to inject script URLs in the entities stored in the catalog. If users of the catalog then click on said URLs, that can lead to an XSS attack. ### Patches This vulnerability has been patched in both the frontend and backend implementations. The default `Link` component from `@backstage/core-components` will now reject `javascript:` URLs, and there is a global override of `window.open` to do the same. In addition the catalog model as well as the catalog
O3 Security · Impact-Aware SCA

Is GHSA-7hv8-3fr9-j2hv in your dependencies?

Find it across npm, including transitive dependencies.

Cross site scripting Vulnerability in backstage Software…