CVE-2023-25571 is a medium-severity (CVSS 6.8) Cross-site Scripting (XSS) vulnerability in @backstage/core-components. A fix is available for @backstage/core-components — see the affected versions and patch details below.
Backstage has XSS Vulnerability in Software Catalog
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2023-25571.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@backstage/core-componentsnpm@backstage/catalog-modelnpm@backstage/plugin-catalog-backendnpmDescription
Backstage is an open platform for building developer portals. @backstage/catalog-model prior to version 1.2.0, @backstage/core-components prior to 0.12.4, and @backstage/plugin-catalog-backend prior to 1.7.2 are affected by a cross-site scripting vulnerability. This vulnerability allows a malicious actor with access to add or modify content in an instance of the Backstage software catalog to inject script URLs in the entities stored in the catalog. If users of the catalog then click on said URLs, that can lead to an XSS attack.
This vulnerability has been patched in both the frontend and backend implementations. The default Link component from @backstage/core-components version 1.2.0 and greater will now reject javascript: URLs, and there is a global override of window.open to do the same. In addition, the catalog model v0.12.4 and greater as well as the catalog backend v1.7.2 and greater now has additional validation built in that prevents javascript: URLs in known annotations. As a workaround, the general practice of limiting access to modifying catalog content and requiring code reviews greatly help mitigate this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @backstage/core-components | all versions | 0.12.4npm install @backstage/core-components@0.12.4 |
| 📦npm | @backstage/catalog-model | all versions | 1.2.0npm install @backstage/catalog-model@1.2.0 |
| 📦npm | @backstage/plugin-catalog-backend | all versions | 1.7.2npm install @backstage/plugin-catalog-backend@1.7.2 |
Affected Products
backstage catalog-modellinuxfoundationbackstage core-componentslinuxfoundationbackstage plugin-catalog-backendlinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @backstage/core-components, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @backstage/core-components to 0.12.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-25571 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2023-25571 in your dependencies?
Find it across npm, including transitive dependencies.