NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

MODX Revolution cross-site scripting vulnerabilityGHSA-7hhg-xj2h-5vq9

MEDIUMFix: modxcms/revolution#13415

GHSA-7hhg-xj2h-5vq9 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in modx/revolution. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for modx/revolution — see the affected versions and patch details below.

Also known asCVE-2017-9070
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.00%0.35%0.71%1.06%0.2%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘modx/revolution

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In MODX Revolution before 2.5.7, a user with resource edit permissions can inject an XSS payload into the title of any post via the pagetitle parameter to connectors/index.php.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmodx/revolutionall versions2.5.7composer require modx/revolution:^2.5.7

Affected Products

1 product · 1 configurations
Application
modx revolutionmodx
≤ 2.5.6
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for modx/revolution, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update modx/revolution to 2.5.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-7hhg-xj2h-5vq9 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In MODX Revolution before 2.5.7, a user with resource edit permissions can inject an XSS payload into the title of any post via the pagetitle parameter to connectors/index.php.
O3 Security · Impact-Aware SCA

Is GHSA-7hhg-xj2h-5vq9 in your dependencies?

Find it across Packagist, including transitive dependencies.

MODX Revolution cross-site scripting vulnerability