NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-9068 — revolution

MEDIUMFix: modxcms/revolution#13424

CVE-2017-9068 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in modx/revolution. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for modx/revolution — see the affected versions and patch details below.

MODX Revolution Reflected XSS

Also known asGHSA-vrw6-7vgj-vj7x
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.40%0.79%1.19%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘modx/revolution

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In MODX Revolution before 2.5.7, an attacker is able to trigger Reflected XSS by injecting payloads into several fields on the setup page, as demonstrated by the database_type parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmodx/revolutionall versions2.5.7composer require modx/revolution:^2.5.7

Affected Products

1 product · 1 configurations
Application
modx revolutionmodx
≤ 2.5.6
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for modx/revolution, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update modx/revolution to 2.5.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-9068 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

In MODX Revolution before 2.5.7, an attacker is able to trigger Reflected XSS by injecting payloads into several fields on the setup page, as demonstrated by the database_type parameter.
O3 Security · Impact-Aware SCA

Is CVE-2017-9068 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-9068: revolution XSS — Fixed in 2.5.7