NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2018-20757 — revolution

MEDIUMFix: modxcms/revolution@489b13c

CVE-2018-20757 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in modx/revolution. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for modx/revolution — see the affected versions and patch details below.

MODX Revolution allows XSS through extended user fields

Also known asGHSA-gm2g-65wj-43g8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.91%1.36%0.2%0.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘modx/revolution

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

MODX Revolution through v2.7.0-pl allows XSS via an extended user field such as a Container name or Attribute name.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmodx/revolutionall versions2.7.1-plcomposer require modx/revolution:^2.7.1-pl

Affected Products

1 product · 2 configurations
Application
modx revolutionmodx
≤ 2.7.0
1 version
2.7.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for modx/revolution, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update modx/revolution to 2.7.1-pl or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-20757 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

MODX Revolution through v2.7.0-pl allows XSS via an extended user field such as a Container name or Attribute name.
O3 Security · Impact-Aware SCA

Is CVE-2018-20757 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2018-20757: revolution XSS — Fixed in 2.7.1-pl