NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2017-9067 — revolution

HIGHFix: modxcms/revolution#13422

CVE-2017-9067 is a high-severity (CVSS 7) Path Traversal vulnerability in modx/revolution. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for modx/revolution — see the affected versions and patch details below.

MODX Revolution Directory Traversal Vulnerability

Also known asGHSA-cgrv-6h2h-6f7v
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.45%0.90%1.35%0.2%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘modx/revolution

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In MODX Revolution before 2.5.7, when PHP 5.3.3 is used, an attacker is able to include and execute arbitrary files on the web server due to insufficient validation of the action parameter to setup/index.php, aka directory traversal.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmodx/revolutionall versions2.5.7composer require modx/revolution:^2.5.7

Affected Products

2 products · 2 configurations
Application
modx revolutionmodx
1 version
2.5.6
Application
phpphp
1 version
5.3.3
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for modx/revolution, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update modx/revolution to 2.5.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-9067 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

In MODX Revolution before 2.5.7, when PHP 5.3.3 is used, an attacker is able to include and execute arbitrary files on the web server due to insufficient validation of the action parameter to setup/index.php, aka directory traversal.
O3 Security · Impact-Aware SCA

Is CVE-2017-9067 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-9067: revolution Path Traversal — Fixed in 2.5.7