NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎 RubyGems
Not in CISA KEV

Avo has a XSS vulnerability on `return_to` paramGHSA-762r-27w2-q22j

Fix: avo-hq/avo#4330

GHSA-762r-27w2-q22j is a Cross-site Scripting (XSS) vulnerability in avo. A fix is available for avo — see the affected versions and patch details below.

Also known asCVE-2026-33209
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-762r-27w2-q22j.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs19th percentile — riskier than 19% of all scored CVEsHighest risk
0.00%0.28%0.56%0.83%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
💎avo

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Description

A reflected cross-site scripting (XSS) vulnerability exists in the return_to query parameter used in the avo interface.

An attacker can craft a malicious URL that injects arbitrary JavaScript, which is executed when he clicks a dynamically generated navigation button.

Impact

This vulnerability may allow execution of arbitrary JavaScript in the context of the application.

Impact varies depending on deployment:

  • In unauthenticated setups: exploitable via crafted links sent to users
  • In authenticated setups: limited to authenticated users and requires interaction

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsavoall versions3.30.3bundle update avo --conservative

Affected Products

1 product · 1 configurations
Application
avoavohq
< 3.30.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for avo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update avo to 3.30.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-762r-27w2-q22j is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

## Description A reflected cross-site scripting (XSS) vulnerability exists in the `return_to` query parameter used in the avo interface. An attacker can craft a malicious URL that injects arbitrary JavaScript, which is executed when he clicks a dynamically generated navigation button. ## Impact This vulnerability may allow execution of arbitrary JavaScript in the context of the application. Impact varies depending on deployment: - In unauthenticated setups: exploitable via crafted links sent to users - In authenticated setups: limited to authenticated users and requires interaction
O3 Security · Impact-Aware SCA

Is GHSA-762r-27w2-q22j in your dependencies?

Find it across RubyGems, including transitive dependencies.

Avo has a XSS vulnerability on `return_to` param