CVE-2024-22191 is a high-severity (CVSS 7.3) Cross-site Scripting (XSS) vulnerability in avo. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for avo — see the affected versions and patch details below.
Stored cross-site scripting (XSS) in `key_value` field in Avo
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-22191.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
avo💎avoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A stored cross-site scripting (XSS) vulnerability was found in the key_value field of Avo v3.2.3. This vulnerability could allow an attacker to execute arbitrary JavaScript code in the victim's browser.
Details
The value of the key_value is inserted directly into the HTML code. In the current version of Avo (possibly also older versions), the value is not properly sanitized before it is inserted into the HTML code.
This vulnerability can be exploited by an attacker to inject malicious JavaScript code into the key_value field. When a victim views the page containing the malicious code, the code will be executed in their browser.
In avo/fields/common/key_value_component.html.erb the value is taken in lines 38 and 49 and seems to be interpreted directly as html in lines 44 and 55.
PoC

To reproduce the vulnerability, follow these steps:
- Edit an entry with a key_value field.
- Enter the following payload into the value field:
POC\"> <script>alert( 'XSS in key_value' );</script> <strong>Outside-tag</strong - Save the entry.
- Go to the index page and click on the eye icon next to the entry.
The malicious JavaScript code will be executed and an alert box will be displayed. On the show and edit page the alert seems not to pop up, but the strong tag breaks out of the expected html tag
Impact
This vulnerability could be used to steal sensitive information from victims that could be used to hijack victims' accounts or redirect them to malicious websites.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | avo | ≥ 3.0.0.beta1&&< 3.2.4 | 3.2.4bundle update avo --conservative |
| 💎RubyGems | avo | all versions | 2.47.0bundle update avo --conservative |
Affected Products
avoavohqResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for avo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update avo to 3.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-22191 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2024-22191 in your dependencies?
Find it across RubyGems, including transitive dependencies.