Path traversal in org.postgresql:postgresqlGHSA-727h-hrw8-jg8q
Fix: pgjdbc/pgjdbc#2454GHSA-727h-hrw8-jg8q is a security vulnerability in org.postgresql:postgresql. A fix is available for org.postgresql:postgresql — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.postgresql:postgresqlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In pgjdbc before 42.3.3, an attacker (who controls the jdbc URL or properties) can call java.util.logging.FileHandler to write to arbitrary files through the loggerFile and loggerLevel connection properties. An example situation is that an attacker could create an executable JSP file under a Tomcat web root. NOTE: the vendor's position is that there is no pgjdbc vulnerability; instead, it is a vulnerability for any application to use the pgjdbc driver with untrusted connection properties.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.postgresql:postgresql | ≥ 42.1.0&&< 42.3.3 | 42.3.3org.postgresql:postgresql:42.3.3 |
Affected Products
debian linuxdebianpostgresql jdbc driverpostgresqlDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.postgresql:postgresql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.postgresql:postgresql to 42.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-727h-hrw8-jg8q is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat informs that although there's a difference from NVD CVSSv3 score there's a especial occasion in this CVE that maintain it as a moderate. The scenario for an attacker to get a benefit in this situation requires them to have access to modify a configuration file and write a file where it's needed. This require…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Fuse 7.11 | jdbc-postgresql | RHSA-2022:5532 |
| RHINT Service Registry 2.3.0 GA | jdbc-postgresql | RHSA-2022:6835 |
| RHPAM 7.13.1 async | jdbc-postgresql | RHSA-2022:6813 |
Frequently Asked Questions
Is GHSA-727h-hrw8-jg8q in your dependencies?
Find it across Maven, including transitive dependencies.